NPTEL Programming, Data Structures And Algorithms Using Python Week-5 August 2023

 

Week 5 Programming Assignment

Due on 2023-08-31, 23:59 IST

For this assignment, you have to write a complete Python program. Paste your code in the window below.

  • You may define additional auxiliary functions as needed.
  • In all cases you may assume that the input to your program has the expected format, so your program does not have to check for malformed inputs.
  • There are some public test cases and some (hidden) private test cases.
  • "Compile and run" will evaluate your submission against the public test cases.
  • "Submit" will evaluate your submission against the hidden private test cases. There are 6 private test cases, with equal weightage. You will get feedback about which private test cases pass or fail, though you cannot see the actual test cases.
  • Ignore warnings about "Presentation errors".


The academic office at the Hogwarts School of Witchcraft and Wizardry has compiled data about students' grades. The data is provided as text from standard input in three parts: information about courses, information about students and information about grades. Each part has a specific line format, described below..

  1. Information about courses
    Line format: Course Code~Course Name~Semester~Year~Instructor
  2. Information about students
    Line format: Roll Number~Full Name
  3. Information about grades
    Line format: Course Code~Semester~Year~Roll Number~Grade

The possible grades are A, AB, B, BC, C, CD, D with corresponding grade points 10, 9, 8, 7, 6, 5 and 4. The grade point average of a student is the sum of his/her grade points divided by the number of courses. For instance, if a student has taken two courses with grades A and C, the grade point average is 8.50 = (10+7)÷2. If a student has not completed any courses, the grade point average is defined to be 0.

You may assume that the data is internally consistent. For every grade, there is a corresponding course code and roll number in the input data.

Each section of the input starts with a line containing a single keyword. The first section begins with a line containing Courses. The second section begins with a line containing Students. The third section begins with a line containing Grades. The end of the input is marked by a line containing EndOfInput.

Write a Python program to read the data as described above and print out a line listing the grade point average for each student in the following format:

Roll Number~Full Name~Grade Point Average

Your output should be sorted by Roll Number. The grade point average should be rounded off to 2 digits after the decimal point. Use the built-in function round().

Here is a sample input and its corresponding output.

Sample Input

Courses
TRAN~Transfiguration~1~2011-2012~Minerva McGonagall
CHAR~Charms~1~2011-2012~Filius Flitwick
Students
SLY2301~Hannah Abbott
SLY2302~Euan Abercrombie
SLY2303~Stewart Ackerley
SLY2304~Bertram Aubrey
SLY2305~Avery
SLY2306~Malcolm Baddock
SLY2307~Marcus Belby
SLY2308~Katie Bell
SLY2309~Sirius Orion Black
Grades
TRAN~1~2011-2012~SLY2301~AB
TRAN~1~2011-2012~SLY2302~B
TRAN~1~2011-2012~SLY2303~B
TRAN~1~2011-2012~SLY2305~A
TRAN~1~2011-2012~SLY2306~BC
TRAN~1~2011-2012~SLY2308~A
TRAN~1~2011-2012~SLY2309~AB
CHAR~1~2011-2012~SLY2301~A
CHAR~1~2011-2012~SLY2302~BC
CHAR~1~2011-2012~SLY2303~B
CHAR~1~2011-2012~SLY2305~BC
CHAR~1~2011-2012~SLY2306~C
CHAR~1~2011-2012~SLY2307~B
CHAR~1~2011-2012~SLY2308~AB
EndOfInput

Sample Output

SLY2301~Hannah Abbott~9.5
SLY2302~Euan Abercrombie~7.5
SLY2303~Stewart Ackerley~8.0
SLY2304~Bertram Aubrey~0
SLY2305~Avery~8.5
SLY2306~Malcolm Baddock~6.5
SLY2307~Marcus Belby~8.0
SLY2308~Katie Bell~9.5
SLY2309~Sirius Orion Black~9.0
Your last recorded submission was on 2023-08-22, 17:14 IST
Select the Language for this assignment. 
# Convert letter grade to grade point
def gradetonum(grade):
    if grade == 'A':
        return(10)
    elif grade == 'AB':
        return(9)
    elif grade == 'B':
        return(8)
    elif grade == 'BC':
        return(7)
    elif grade == 'C':
        return(6)
    elif grade == 'CD':
        return(5)
    elif grade == 'D':
        return(4)
    else:
        return(0)
                   
# Set up three dictionaries to store data
rollname = {}    # Key: roll number, Value: Name
gradepoint = {}  # Key: roll number, Value: Cumulative grade points
coursecount = {} # Key: roll number, Value: Number of courses taken
 
nextline = input().strip()
while nextline.find("Courses") < 0:
    nextline = input().strip()
 
# Read course data
while nextline.find("Students") < 0:
    nextline = input().strip()
    # Course data is irrelevant for this problem!
 
# Read students data
nextline = input().strip()
while nextline.find("Grades") < 0:
    fields = nextline.split('~')
    roll=fields[0]
    name=fields[1]
    rollname[roll] = name   # Initialize
    gradepoint[roll] = 0    # Initialize
    coursecount[roll] = 0   # Initialize
    nextline = input().strip()
 
# Read grades data
nextline = input().strip()
while nextline.find("EndOfInput") < 0:
    fields = nextline.split('~')
    roll=fields[3]
    grade=fields[4]
    gradepoint[roll] += gradetonum(grade)  # Update
    coursecount[roll] += 1                 # Update
    nextline = input().strip()
 
# Print output
for roll in sorted(rollname.keys()):
    if coursecount[roll] > 0:
        gpa = round(gradepoint[roll]/coursecount[roll],2)
    else:
        gpa = 0
    print(roll,rollname[roll],gpa,sep='~',end='\n' )
 
You may submit any number of times before the due date. The final submission will be considered for grading.
This assignment has Public Test cases. Please click on "Compile & Run" button to see the status of Public test cases. Assignment will be evaluated only after submitting using Submit button below. If you only save as or compile and run the Program , your assignment will not be graded and you will not see your score after the deadline.
   



Private Test cases used for EvaluationStatus
Test Case 1
Passed
Test Case 2
Passed
Test Case 3
Passed
Test Case 4
Passed
Test Case 5
Passed
Test Case 6
Passed


No comments

JavaFX Scene Builder

  This is an article about the JavaFX Scene Builder. You will get a short introduction about the installation and usage of the software. The...